summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml72
1 files changed, 72 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..f91599d
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,72 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "uniffi"
+version = "0.26.1"
+authors = ["Firefox Sync Team <sync-team@mozilla.com>"]
+description = "a multi-language bindings generator for rust"
+homepage = "https://mozilla.github.io/uniffi-rs"
+documentation = "https://mozilla.github.io/uniffi-rs"
+readme = "README.md"
+keywords = [
+ "ffi",
+ "bindgen",
+]
+license = "MPL-2.0"
+repository = "https://github.com/mozilla/uniffi-rs"
+
+[dependencies.anyhow]
+version = "1"
+
+[dependencies.camino]
+version = "1.0.8"
+optional = true
+
+[dependencies.clap]
+version = "4"
+features = [
+ "cargo",
+ "std",
+ "derive",
+]
+optional = true
+
+[dependencies.uniffi_bindgen]
+version = "=0.26.1"
+optional = true
+
+[dependencies.uniffi_build]
+version = "=0.26.1"
+optional = true
+
+[dependencies.uniffi_core]
+version = "=0.26.1"
+
+[dependencies.uniffi_macros]
+version = "=0.26.1"
+
+[dev-dependencies.trybuild]
+version = "1"
+
+[features]
+bindgen = ["dep:uniffi_bindgen"]
+bindgen-tests = ["dep:uniffi_bindgen"]
+build = ["dep:uniffi_build"]
+cli = [
+ "bindgen",
+ "uniffi_bindgen?/clap",
+ "dep:clap",
+ "dep:camino",
+]
+default = []
+tokio = ["uniffi_core/tokio"]