summaryrefslogtreecommitdiff
path: root/tests/pkgconfig/bare/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/pkgconfig/bare/CMakeLists.txt')
-rw-r--r--tests/pkgconfig/bare/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/tests/pkgconfig/bare/CMakeLists.txt b/tests/pkgconfig/bare/CMakeLists.txt
new file mode 100644
index 0000000..866831a
--- /dev/null
+++ b/tests/pkgconfig/bare/CMakeLists.txt
@@ -0,0 +1,23 @@
+cmake_minimum_required(VERSION 3.0)
+
+project(PkgConfigTest
+ LANGUAGES C
+)
+
+find_package(OpenCLHeaders
+ REQUIRED
+ CONFIG
+)
+
+add_executable(${PROJECT_NAME}
+ ../pkgconfig.c
+)
+
+target_link_libraries(${PROJECT_NAME}
+ OpenCL::Headers
+)
+
+target_compile_definitions(${PROJECT_NAME}
+ PRIVATE
+ CL_TARGET_OPENCL_VERSION=120
+)