summaryrefslogtreecommitdiff
path: root/dev-embedded/sunxi-tools/sunxi-tools-1.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-embedded/sunxi-tools/sunxi-tools-1.2.ebuild')
-rw-r--r--dev-embedded/sunxi-tools/sunxi-tools-1.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-embedded/sunxi-tools/sunxi-tools-1.2.ebuild b/dev-embedded/sunxi-tools/sunxi-tools-1.2.ebuild
new file mode 100644
index 0000000000..4668be33cd
--- /dev/null
+++ b/dev-embedded/sunxi-tools/sunxi-tools-1.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+MY_PV="v${PV}"
+SRC_URI="https://github.com/linux-sunxi/sunxi-tools/archive/${MY_PV}.tar.gz"
+
+DESCRIPTION="Tools for Allwinner A10 devices."
+HOMEPAGE="http://linux-sunxi.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64"
+
+DEPEND="virtual/libusb"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} -std=c99 -D_POSIX_C_SOURCE=200112L -Iinclude/" all misc
+}
+
+src_install() {
+ dobin bin2fex bootinfo fel fex2bin fexc nand-part phoenix_info pio
+}