summaryrefslogtreecommitdiff
path: root/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild')
-rw-r--r--dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild b/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild
new file mode 100644
index 0000000000..98afcc8f62
--- /dev/null
+++ b/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/depthimage_to_laserscan"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Converts a depth image to a laser scan for use with navigation and localization"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/image_geometry
+ dev-ros/nodelet
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"