summaryrefslogtreecommitdiff
path: root/dev-ros/xmlrpcpp/xmlrpcpp-1.11.15-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/xmlrpcpp/xmlrpcpp-1.11.15-r1.ebuild')
-rw-r--r--dev-ros/xmlrpcpp/xmlrpcpp-1.11.15-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/xmlrpcpp/xmlrpcpp-1.11.15-r1.ebuild b/dev-ros/xmlrpcpp/xmlrpcpp-1.11.15-r1.ebuild
new file mode 100644
index 0000000000..b4772f1846
--- /dev/null
+++ b/dev-ros/xmlrpcpp/xmlrpcpp-1.11.15-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=utilities/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="C++ implementation of the XML-RPC protocol"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-ros/cpp_common"
+DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/headers.patch" )
+
+src_configure() {
+ ros-catkin_src_configure
+ # Hack so that proper -I are added
+ sed -e "s#_include_dirs \"include\"#_include_dirs \"include;${SYSROOT:-${EPREFIX}}/usr/include/xmlrpcpp\"#" \
+ -i "${BUILD_DIR}/catkin_generated/installspace/xmlrpcppConfig.cmake" || die
+}