aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml13
1 files changed, 7 insertions, 6 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 65168d5..0165453 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -10,9 +10,9 @@
# See Cargo.toml.orig for the original contents.
[package]
-rust-version = "1.40.0"
+rust-version = "1.48.0"
name = "libloading"
-version = "0.7.4"
+version = "0.8.1"
authors = ["Simonas Kazlauskas <libloading@kazlauskas.me>"]
description = "Bindings around the platform's dynamic library loading primitives with greatly improved memory safety."
documentation = "https://docs.rs/libloading/"
@@ -43,9 +43,10 @@ version = "1.1"
[target."cfg(unix)".dependencies.cfg-if]
version = "1"
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3"
+[target."cfg(windows)".dependencies.windows-sys]
+version = "0.48"
features = [
- "errhandlingapi",
- "libloaderapi",
+ "Win32_Foundation",
+ "Win32_System_Diagnostics_Debug",
+ "Win32_System_LibraryLoader",
]