aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml84
1 files changed, 49 insertions, 35 deletions
diff --git a/Cargo.toml b/Cargo.toml
index e07072c..320fd4c 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -11,15 +11,21 @@
[package]
edition = "2018"
+rust-version = "1.60.0"
name = "uuid"
-version = "1.3.0"
+version = "1.7.0"
authors = [
"Ashley Mannix<ashleymannix@live.com.au>",
"Christopher Armstrong",
"Dylan DPC<dylan.dpc@gmail.com>",
"Hunar Roop Kahlon<hunar.roop@gmail.com>",
]
-exclude = [".github/**"]
+include = [
+ "src",
+ "README.md",
+ "LICENSE-APACHE",
+ "LICENSE-MIT",
+]
description = "A library to generate and parse UUIDs."
homepage = "https://github.com/uuid-rs/uuid"
documentation = "https://docs.rs/uuid"
@@ -39,19 +45,11 @@ license = "Apache-2.0 OR MIT"
repository = "https://github.com/uuid-rs/uuid"
[package.metadata.docs.rs]
-rustc-args = [
- "--cfg",
- "uuid_unstable",
-]
-rustdoc-args = [
- "--cfg",
- "uuid_unstable",
-]
-targets = ["x86_64-unknown-linux-gnu"]
features = [
"serde",
"arbitrary",
"slog",
+ "borsh",
"v1",
"v3",
"v4",
@@ -60,6 +58,15 @@ features = [
"v7",
"v8",
]
+rustc-args = [
+ "--cfg",
+ "uuid_unstable",
+]
+rustdoc-args = [
+ "--cfg",
+ "uuid_unstable",
+]
+targets = ["x86_64-unknown-linux-gnu"]
[package.metadata.playground]
features = [
@@ -81,23 +88,34 @@ optional = true
version = "0.5"
optional = true
default-features = false
-package = "atomic"
+
+[dependencies.borsh]
+version = "1"
+optional = true
+default-features = false
+
+[dependencies.borsh-derive]
+version = "1"
+optional = true
+default-features = false
+
+[dependencies.bytemuck]
+version = "1.14.0"
+features = ["derive"]
+optional = true
[dependencies.getrandom]
version = "0.2"
optional = true
-package = "getrandom"
[dependencies.md-5]
version = "0.10"
optional = true
default-features = false
-package = "md-5"
[dependencies.rand]
version = "0.8"
optional = true
-package = "rand"
[dependencies.serde]
version = "1.0.56"
@@ -108,21 +126,18 @@ default-features = false
version = "1"
optional = true
default-features = false
-package = "sha1_smol"
[dependencies.slog]
version = "2"
optional = true
[dependencies.uuid-macro-internal]
-version = "1.3.0"
+version = "1.7.0"
optional = true
-package = "uuid-macro-internal"
[dependencies.wasm-bindgen]
version = "0.2"
optional = true
-package = "wasm-bindgen"
[dependencies.zerocopy]
version = "0.6"
@@ -147,20 +162,24 @@ version = "1.0.56"
version = "1.0.52"
[features]
+atomic = ["dep:atomic"]
+borsh = [
+ "dep:borsh",
+ "dep:borsh-derive",
+]
default = ["std"]
fast-rng = [
"rng",
- "rand",
+ "dep:rand",
]
js = [
- "wasm-bindgen",
- "getrandom",
- "getrandom/js",
+ "dep:wasm-bindgen",
+ "getrandom?/js",
]
-macro-diagnostics = ["uuid-macro-internal"]
-md5 = ["md-5"]
-rng = ["getrandom"]
-sha1 = ["sha1_smol"]
+macro-diagnostics = ["dep:uuid-macro-internal"]
+md5 = ["dep:md-5"]
+rng = ["dep:getrandom"]
+sha1 = ["dep:sha1_smol"]
std = []
v1 = ["atomic"]
v3 = ["md5"]
@@ -173,16 +192,11 @@ v7 = [
]
v8 = []
-[target."cfg(target_arch = \"wasm32\")".dev-dependencies.wasm-bindgen]
-version = "0.2"
-package = "wasm-bindgen"
-
-[target."cfg(target_arch = \"wasm32\")".dev-dependencies.wasm-bindgen-test]
+[target."cfg(all(target_arch = \"wasm32\", target_vendor = \"unknown\", target_os = \"unknown\"))".dev-dependencies.wasm-bindgen-test]
version = "0.3"
-[target."cfg(windows)".dev-dependencies.windows-sys]
-version = "0.45.0"
-features = ["Win32_System_Com"]
+[target."cfg(target = \"wasm32-unknown-unknown\")".dev-dependencies.wasm-bindgen]
+version = "0.2"
[badges.is-it-maintained-issue-resolution]
repository = "uuid-rs/uuid"