summaryrefslogtreecommitdiff
path: root/peripheral/libmraa/imraa/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'peripheral/libmraa/imraa/CMakeLists.txt')
-rw-r--r--peripheral/libmraa/imraa/CMakeLists.txt17
1 files changed, 0 insertions, 17 deletions
diff --git a/peripheral/libmraa/imraa/CMakeLists.txt b/peripheral/libmraa/imraa/CMakeLists.txt
deleted file mode 100644
index a5c9156..0000000
--- a/peripheral/libmraa/imraa/CMakeLists.txt
+++ /dev/null
@@ -1,17 +0,0 @@
-add_executable (imraa imraa.c)
-
-include_directories (${PROJECT_SOURCE_DIR}/api)
-include_directories (${PROJECT_SOURCE_DIR}/include)
-include_directories (${PROJECT_SOURCE_DIR}/api/mraa)
-
-set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -DIMRAA=1")
-
-find_package (JSON-C REQUIRED)
-include_directories (${JSON-C_INCLUDE_DIR})
-find_package (UDEV REQUIRED)
-include_directories (${UDEV_INCLUDE_DIR})
-target_link_libraries (imraa mraa ${JSON-C_LIBRARIES} ${UDEV_LIBRARIES})
-
-set_property (TARGET imraa PROPERTY C_STANDARD 99)
-
-install (TARGETS imraa DESTINATION bin)