aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 12 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index ca293669..bfee372a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -37,7 +37,7 @@ AC_CONFIG_MACRO_DIR([m4])
AC_CANONICAL_HOST
AM_INIT_AUTOMAKE(subdir-objects tar-ustar 1.13)
-AM_CONFIG_HEADER(src/config.h)
+AC_CONFIG_HEADERS(src/config.h)
AM_MAINTAINER_MODE
AM_PROG_AR
@@ -59,15 +59,6 @@ if test "x$enable_m32" = xyes; then
CXXFLAGS="${CXXFLAGS} -m32"
fi
-m4_warn([obsolete],
-[The preprocessor macro `STDC_HEADERS' is obsolete.
- Except in unusual embedded environments, you can safely include all
- ISO C90 headers unconditionally.])dnl
-# Autoupdate added the next two lines to ensure that your configure
-# script's behavior did not change. They are probably safe to remove.
-AC_CHECK_INCLUDES_DEFAULT
-AC_PROG_EGREP
-
AC_SYS_LARGEFILE
AX_PTHREAD
AC_CHECK_HEADERS([a.out.h sys/mman.h sys/random.h])
@@ -221,6 +212,17 @@ fi
AC_ARG_VAR([RUSTC_DEMANGLE_CFLAGS], [Compiler flags for rustc-demangle])
AC_ARG_VAR([RUSTC_DEMANGLE_LIBS], [Linker flags for rustc-demangle])
+AC_ARG_ENABLE(zstd,
+ AS_HELP_STRING([--enable-zstd],
+ [Enable decompression of ELF sections with zstd]),,
+ [enable_zstd=no])
+if test "x${enable_zstd}" != xno; then
+ AC_CHECK_LIB(zstd, ZSTD_decompress, [],
+ [AC_MSG_ERROR([zstd library not found.])])
+ AC_CHECK_HEADER(zstd.h, [],
+ [AC_MSG_ERROR([zstd header not found.])])
+fi
+
AC_ARG_WITH(tests-as-root,
AS_HELP_STRING([--with-tests-as-root],
[Run the tests as root. Use this on platforms]