aboutsummaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build9
1 files changed, 5 insertions, 4 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 5f3ac9df..1c1ddf07 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -1,8 +1,9 @@
# Tests that link to libopus
opus_tests = [
['test_opus_api'],
- ['test_opus_decode', [], 60],
- ['test_opus_encode', 'opus_encode_regressions.c', 120],
+ ['test_opus_decode', [], 120],
+ ['test_opus_encode', 'opus_encode_regressions.c', 240],
+ ['test_opus_extensions', [], 120],
['test_opus_padding'],
['test_opus_projection'],
]
@@ -18,9 +19,9 @@ foreach t : opus_tests
exe_kwargs = {}
# This test uses private symbols
- if test_name == 'test_opus_projection'
+ if test_name == 'test_opus_projection' or test_name == 'test_opus_extensions'
exe_kwargs = {
- 'link_with': [celt_lib, silk_lib],
+ 'link_with': [celt_lib, silk_lib, dnn_lib],
'objects': opus_lib.extract_all_objects(),
}
endif