aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml33
1 files changed, 11 insertions, 22 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 028ae0e..50ed048 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,46 +3,35 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies.
+# to registry (e.g., crates.io) dependencies
#
-# If you are reading this file be aware that the original Cargo.toml
-# will likely look very different (and much more reasonable).
-# See Cargo.toml.orig for the original contents.
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
[package]
edition = "2018"
-rust-version = "1.36"
name = "either"
-version = "1.8.1"
+version = "1.9.0"
authors = ["bluss"]
-description = """
-The enum `Either` with variants `Left` and `Right` is a general purpose sum type with two cases.
-"""
+description = "The enum `Either` with variants `Left` and `Right` is a general purpose sum type with two cases.\n"
documentation = "https://docs.rs/either/1/"
readme = "README-crates.io.md"
-keywords = [
- "data-structure",
- "no_std",
-]
-categories = [
- "data-structures",
- "no-std",
-]
+keywords = ["data-structure", "no_std"]
+categories = ["data-structures", "no-std"]
license = "MIT OR Apache-2.0"
repository = "https://github.com/bluss/either"
+[package.metadata.docs.rs]
+features = ["serde"]
[package.metadata.release]
no-dev-version = true
tag-name = "{{version}}"
-
-[package.metadata.docs.rs]
-features = ["serde"]
-
[dependencies.serde]
version = "1.0"
features = ["derive"]
optional = true
-
[dev-dependencies.serde_json]
version = "1.0.0"