aboutsummaryrefslogtreecommitdiff
path: root/macro/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'macro/Cargo.toml')
-rw-r--r--macro/Cargo.toml22
1 files changed, 12 insertions, 10 deletions
diff --git a/macro/Cargo.toml b/macro/Cargo.toml
index 89d97022..c81bc093 100644
--- a/macro/Cargo.toml
+++ b/macro/Cargo.toml
@@ -1,10 +1,10 @@
[package]
name = "cxxbridge-macro"
-version = "1.0.93"
+version = "1.0.119"
authors = ["David Tolnay <dtolnay@gmail.com>"]
categories = ["development-tools::ffi"]
description = "Implementation detail of the `cxx` crate."
-edition = "2018"
+edition = "2021"
exclude = ["build.rs", "README.md"]
homepage = "https://cxx.rs"
keywords = ["ffi"]
@@ -18,22 +18,24 @@ proc-macro = true
[features]
# incomplete features that are not covered by a compatibility guarantee:
experimental-async-fn = []
-experimental-enum-variants-from-header = ["clang-ast", "flate2", "memmap", "serde", "serde_json"]
+experimental-enum-variants-from-header = ["clang-ast", "flate2", "memmap", "serde", "serde_derive", "serde_json"]
[dependencies]
-proc-macro2 = "1.0.39"
-quote = "1.0.4"
-syn = { version = "2.0.1", features = ["full"] }
+proc-macro2 = "1.0.74"
+quote = "1.0.35"
+syn = { version = "2.0.46", features = ["full"] }
# optional dependencies:
-clang-ast = { version = "0.1", optional = true }
-flate2 = { version = "1.0", optional = true }
+clang-ast = { version = "0.1.18", optional = true }
+flate2 = { version = "1.0.26", optional = true }
memmap = { version = "0.7", optional = true }
-serde = { version = "1.0", optional = true, features = ["derive"] }
-serde_json = { version = "1.0", optional = true }
+serde = { version = "1.0.166", optional = true }
+serde_derive = { version = "1.0.166", optional = true }
+serde_json = { version = "1.0.100", optional = true }
[dev-dependencies]
cxx = { version = "1.0", path = ".." }
[package.metadata.docs.rs]
targets = ["x86_64-unknown-linux-gnu"]
+rustdoc-args = ["--generate-link-to-definition"]